
ขัน้ตอนในการสร้าง Web page

สร้าง Folder หรือ Site สําหรับเก็บเอกสาร web page

สร้าง Folder สําหรับเก็บเอกสาร web page

สร้าง Folder สําหรับเก็บข้อมลูรูปภาพ

( การสร้าง Site สําหรับพฒันาเวบ็ไซต์ )

สร้างเอกสาร web page ใน Site ที่สร้างขึน้

ตกแตง่เอกสาร

แสดงผลผ่าน web browser ( กด F12 )



1.1 สร้างโฟลเดอร์สําหรับจดัเก็บไฟล์เวบ็หรือ

ไฟล์อื่น ๆ ที่ใช้ในการสร้างเวบ็ เช่น TestWeb

1.2 สร้างโฟลเดอร์สําหรับจดัเก็บไฟล์ภาพ 

เช่น images ไว้ในโฟลเดอร์หลกั

1. สร้างโฟลเดอร์สาํหรับจัดเกบ็เวบ็เพจ



2. สร้าง Site เพื่อชีก้ารทาํงานไปยังโฟลเดอร์ที่สร้างขึน้

ไปที่เมน ูSite > Manage Sites…

หรือไปที่ panel group ชื่อ Files > Files คลกิที่ Manage Sites…





แสดงชื่อ Site ที่เคยถกูสร้างขึน้ก่อนหน้าหาก

ต้องการเรียกใช้งานให้คลกิเลือกแล้วคลิกปุ่ ม 

Done

หากต้องการสร้างใหมใ่ห้คลกิปุ่ ม 

New… > Site 



เลือก Advanced จะปรากฏหน้าจอรับข้อมลู

ชื่อ Site คลกิเพื่อเลือกโฟลเดอร์ที่

ต้องการเชื่อมโยงกบัโปรแกรม

คลกิเพื่อเลือกโฟลเดอร์

ต้องการใช้เก็บไฟล์ภาพ 

: ชื่อ Site จะต้องไมซ่ํา้กบัชื่อ Site ที่เคยสร้างมาก่อน

: ควรตัง้ชื่อ Site ทกุครัง้แทนการใช้ Unnamed Site…



เริ่มต้นใช้งาน Dreaweaver

สร้างไฟล์ใหม ่โดย

คลกิขวาที่ชื่อ Site > New File > ตัง้ชื่อไฟล์พร้อมระบนุามสกลุของ

ไฟล์เป็น .htm หรือ .html ก็ได้

เมน ูNew > General > Basic Pages > HTML



วิธีที่ 1 คลกิขวาที่ชื่อ 

site > New Fileวิธีที่ 2 คลกิเมน ูFile 

> New…



โปรแกรมจะสร้างไฟล์ใหมใ่ห้ จากนัน้เปลี่ยนชื่อ 

พร้อมระบนุามสกลุเป็น .htm หรือ .html ก็ได้

จากนัน้ double Click ที่ไฟล์ที่สร้างขึน้เพื่อเริ่มต้น

สร้างเว็บเพจตามความต้องการ

วธิีการที่ 1 เมื่อคลิกขวาที่ชื่อ Site > New File



วธิีการที่ 2 เมื่อคลิกเมนู File > New…

1. เลือก General

2. เลือก Basic Page

3. เลือก HTML

4. คลิกเพื่อสร้างไฟล์ใหม่



เครื่องมือพืน้ฐานในการใช้งาน 

Dreamweaver



เครื่องมือช่วยในการสร้าง web page

การจดัการไฟล์ และ Site

กําหนดคณุสมบตัิ



การปรับแต่งพืน้ที่ในการทาํงาน



การปรับแต่งพืน้ที่ในการทาํงาน

คลกิปุ่ ม “Page Properties” ที่หน้าตา่ง Properties Inspector หรือ

คลกิเมน ูModify > Page Properties



วิธีที่ 1 คลกิปุ่ ม 

Page Properties

วิธีที่ 2 คลกิเมน ูModify 

> Properties



Appearance จดัรปแบบหน้าเอกสารเวบ็ู

รูปแบบอกัษรทัง้เอกสาร

ขนาดอกัษร
สีอกัษร

พืน้หลงัเป็นสีหรือ

รูปภาพ

ระยะขอบ

ของเอกสาร



Links จัดรปแบบข้อความที่เป็นจุดเชื่อมโยงู

ขนาดอกัษร

รูปแบบอกัษร

สีอกัษร

รูปแบบเส้น

ใต้



Heading จัดรปแบบหวัข้อใหญู่

รูปแบบอกัษร

สีของหวัข้อใหญ่

แตล่ะขนาด



Title/Encoding กาํหนด Title Bar และการใช้งานภาษา

ข้อความที่จะปรากฏที่ 

Title bar

กําหนดเป็น Thai 

(Windows)



การกาํหนดการใช้งานภาษาไทย

ทกุครัง้ที่สร้างไฟล์ใหม ่ หากต้องการให้สามารถใช้งานภาษาไทย

ไปที่เมน ูEdit > Preferences > Fonts > Thai

3. เลือกรูปแบบ

และขนาดอกัษร

2. เลือก Thai

1. เลือก Fonts



การกําหนดการใช้งานภาษาไทย

ไปที่ Edit > Preferences > New Document > Default Encoding > 

Thai (Windows)

ตวัอยา่งไทย  ตวัอยา่ง UTF-8

1. เลือก New 

Document

2. เลือก Thai

(Windows)



เครื่องมือในการจดัการตวัอักษร



1 2 3 4 5

6 7 8
9

ตวัอยา่ง  การจดัตวัอกัษร

1 กําหนดรูปแบบของหวัข้อ

2 กําหนดรูปแบบตาม Style Sheet

3. กําหนดตวัหนา ตวัเอียง 

4. กําหนดการจดัวางแนวของข้อความ

5. กําหนดการเชื่อมโยงด้วยข้อความ

6. กําหนดรูปแบบอกัษร

7. กําหนดขนาดอกัษร

8. กําหนดสีอกัษร

9. จดัรูปแบบหน้ากระดาษ

10. การใสล่ําดบัหวัข้อยอ่ยและยอ่หน้า

10

** ก่อนจดัรูปแบบข้อความจะต้องเลือกข้อความที่ต้องการจดัรูปแบบก่อนเสมอ **



เครื่องมือพืน้ฐานในการสร้างเวบ็เพจ



การสร้างจดุเชื่อมโยงไปยงัเวบ็ไซต์

การสร้างจดุเชื่อมโยงไปยงัอีเมลล์

การตัง้ชื่อตําแหน่งตา่ง ๆ ในหน้าเวบ็

การแทรกตาราง

การแทรกรูปภาพ

การแทรกไฟล์ประเภท Shock Wave

การแทรกวนัที่

การแทรก comment

การสร้าง Template



เครื่องมือในการจดัการรปภาพู



การแทรกรปภาพู

คลกิที่เมน ูInsert > Image หรือ

คลกิที่ Objects Bar

คลกิ แทรกรูปภาพ

จองพืน้ที่สําหรับแทรกภาพ แทรกรูปภาพแบบสลบั

สร้างจดุเชื่อมโยงบนภาพ

เดียวกนัหลาย ๆ จดุ (Image 

Map)



เครื่องมือในการปรับแต่งรปภาพู

(properties)



คลกิแล้วลากเพื่อปรับ

ขนาด
เปลี่ยนคา่เพื่อปรับขนาด

คําอธิบาย

ภาพ

จดัตําแหน่งของ

ภาพกบัข้อความ

ขนาดเส้นขอบ

จดัตําแหน่ง

ภาพ

ทําให้ภาพกลายเป็น

จดุเชื่อมโยง

สร้าง Image Map

ตําแหน่งของไฟล์



การดผลลัพธ์ทางู  Web Browser



การดผลลัพธ์ทางู เวบ็เบราเซอร์

เมื่อสร้างหน้าเวบ็เพจเสร็จเรียบร้อยสามารถดผูลลพัธ์ได้จาก Web 

Browser โดย

คลกิเมน ูFile > Preview in Browser > iexplore

หรือคลกิที่ปุ่ ม    ที่ tool bar > Preview in iexplore

หรือ กดปุ่ ม F12 ที่คีย์บอร์ด



วิธีที่ 2

วิธีที่ 1



ข้อความที่ Title bar

ผลลพัธ์จากการทํางาน



การแทรกรปภาพู

คลกิที่เมน ูInsert > Image หรือ

คลกิที่ Objects Bar

คลกิ แทรกรูปภาพ

จองพืน้ที่สําหรับแทรก

ภาพ
แทรกรูปภาพแบบ

สลบั

สร้างจดุเชื่อมโยงบนภาพ

เดียวกนัหลาย ๆ จดุ (Image 

Map)



การสลับรปภาพเชื่อมโยงด้วยู  Rollover Image

เป็นเทคนิคที่ชว่ยเพิ่มความน่าสนใจให้กบัเว็บเพจ โดยการทําให้ภาพเปลี่ยนเป็น

ภาพอื่นเมื่อเลื่อนเมาส์มาที่รูปภาพที่เป็นจดุเชื่อม และเมื่อเลื่อนเมาส์ออก จะ

กลบัคืนเป็นภาพเดมิ

ที่แทบ็ common คลกิไอคอน    แล้วคลกิเลือก Rollover Image หรือ

ที่เมน ูInsert > Image Objects > Rollover Image

ตวัอยา่ง Rollover Image



1. คลกิ

2. กําหนดคา่ภาพแรกก่อนเลื่อน

เมาส์ไปวาง

ภาพที่จะเปลี่ยนไป

เมื่อนําเมาส์ไปวางคําอธิบายภาพ

ระบ ุURL หรือไฟล์เว็บเพจ

ปลายทางที่ต้องการ

เชื่อมโยง



การสร้าง Image Map เพื่อการเชื่อมโยง

เป็นการใช้งานรูปภาพเพื่อสร้างจดุเชื่อมโยงหลายจดุภายในรูปภาพเดียวกนั

คลกิไอคอน    เลือกรูปแบบ Map ที่ต้องการ หรือ

ที่ Properties Inspector คลกิเลือกรูปแบบ Map ที่ต้องการ

จากนัน้นํามาวาดบนภาพในบริเวณที่ต้องการ แล้วกําหนดการเชื่อมโยงของ Map 

ที่วาดไว้

ตวัอยา่ง Inspector



วิธีการที่ 1 คลกิที่ไอคอน 

Images แล้วเลือกรูปแบบ 

Map ที่ต้องการ

วิธีการที่ 2 คลกิเลือก

รูปแบบ Map ที่ต้องการ



วาด Map ลงบน

ภาพในบริเวณที่

ต้องการ

กําหนดคา่การ

เชื่อมโยงให้กบั Map 

แตล่ะตวั



เครื่องมือในการปรับแต่งรปภาพู

(properties)



คลกิแล้วลากเพื่อปรับ

ขนาด
เปลี่ยนคา่เพื่อปรับขนาด

คําอธิบาย

ภาพ

จดัตําแหน่งของ

ภาพกบัข้อความ

ขนาดเส้นขอบ

จดัตําแหน่ง

ภาพ

ทําให้ภาพกลายเป็น

จดุเชื่อมโยง

สร้าง Image Map

ตําแหน่งของไฟล์



วิธีที่ 2

วิธีที่ 1



ข้อความที่ Title bar

ผลลพัธ์จากการทํางาน



การแทรกตารางและการจดัรูปแบบตาราง

ตวัอยา่ง  การแสดงผล

ตวัอยา่ง  เบือ้งหลงัการแสดงผล



การแทรกตาราง

คลกิเมน ูInsert > table หรือ

คลกิที่ Objects bar

คลกิ



ระบจุํานวนแถวและ

คอลมัน์ที่ต้องการ

ความกว้าง

ขนาดเส้น

ขอบ

ระยะห่างระหวา่ง

ข้อความกบัขอบ

ระยะห่างระหวา่ง

เซลล์

กําหนดลกัษณะ

ของหวัตาราง กําหนดข้อความ

อธิบายตาราง
จดัตําแหน่ง

คําอธิบายตาราง กําหนดข้อสรุป

ของตารางตวัอยา่ง  การสร้างตาราง



การจดัการกับตาราง

หากต้องการจดัการกบัตารางเกี่ยวกบัการแทรก การลบ การผสาน หรือ

การแยกแถว/คอลมัน์ สามารถทําได้โดย

คลกิเลือกเซลล์ จากนัน้ไปที่เมน ูModify > Table

(ตวัอย่างสร้างตารางใหม่ และมีการซ้อนตาราง)



1

2



การจดัรปแบบเซลล์ข้อมลู ู

คลกิเลือกเซลล์ที่ต้องการจดัรูปแบบ (หรือเลือกหลายเซลล์ก็ได้)

จดัรูปแบบตวัอกัษรภายในตาราง

ผสานและแยก

เซลล์

กําหนดการจดัวางข้อความ

ในแนวนอนและแนวตัง้
กําหนดให้มีการตดัคําเพื่อขึน้บรรทดั

ใหม ่และกําหนดเป็นหวัตาราง

กําหนดพืน้หลงั

เป็นสีหรือรูปภาพ
สีของเส้น

ขอบ



การจดัรปแบบตารางู

คลกิเลือกทัง้หมดของตาราง โดยไปที่เมน ู1. Modify > Table > Select Table 

หรือ 2. คลิกที่เส้นขอบของตาราง

จํานวนแถวและคอลมัน์ ความกว้างและสงู

ระยะหา่งระหวา่ง

ขอบกบัข้อมลู การจดัวางตาราง

ในหน้าเวบ็

ขนาดเส้นขอบ

สีเส้นขอบ
พืน้หลงัเป็นสี

หรือรูปภาพ

จดัการความกว้างของ

คอลมัน์และความสงูของ

แถว



การสร้างการเชื่อมโยง (Links)



ลักษณะการเชื่อมโยง

การเชื่อมโยงภายในเวบ็เพจเดียวกนั

การเชื่อมโยงภายในเวบ็ไซต์เดียวกนั

การเชื่อมโยงไปยงัเวบ็ไซต์อื่น

การเชื่อมโยงไปยงัอีเมล์



สถานะของการเชื่อมโยง

Hyperlink : ไมเ่คยมีการคลิกที่จดุเชื่อมโยง

Active Hyperlink : ผู้ใช้กําลงัคลิกเมาส์ที่จดุเชื่อมโยง

Visited Hyperlink : เคยมีการคลิกที่จดุเชื่อมโยง

Rollover Link : เมื่อเลื่อนเมาส์ไปวางบนจดุเชื่อมโยง

( ตวัอยา่ง สถานการณ์ Link )



การเชื่อมโยงภายในเวบ็ไซต์เดียวกัน

เป็นการเชื่อมโยงจากเวบ็เพจหนึง่  ไปยงัอีกเวบ็เพจหนึง่ โดย

คลกิเลือกข้อความหรือภาพ  ที่ต้องการสร้างเป็นจดุเชื่อมโยง

ที่หน้าตา่ง Properties ในสว่น Link คลิกที่รูปโฟลเดอร์ เพื่อเลือกไฟล์

เวบ็ที่ต้องการเชื่อมโยงไปหาเมื่อคลกิที่จดุเชื่อมโยง

 ตวัอยา่ง การเชื่อมโยง



1. เลือกข้อความหรือภาพ

ที่ต้องการสร้างจดุ

เชื่อมโยง

2. คลกิ

3. คลกิเลือกไฟล์ที่

ต้องการ



การกาํหนดตาํแหน่งเป้าหมาย (Target Link)

เป็นการกําหนดเพื่อให้เวบ็เพจแสดงผลบนหน้าตา่งเวบ็เบราเซอร์ในหน้าตา่งใหม ่

หน้าตา่งเดมิ หรือในเฟรมใด โดย

_blank : แสดงเวบ็เพจในหน้าตา่งใหม่

_parent : แสดงเวบ็เพจในหน้าตา่งเดมิ แทนที่หน้าเว็บเพจเดมิ

_self : แสดงเวบ็เพจในพืน้ที่เดียวกบัที่เป็นจดุเชื่อม

_top : แสดงเวบ็เพจในลกัษณะเดียวกบั _parent

เลือก



การเชื่อมโยงภายในเวบ็เพจเดียวกันด้วย Named Anchor

ใช้ในกรณีที่เว็บเพจนัน้มีเนือ้หามาก ต้องใช้ Scroll Bar เลื่อนไปยงั
เนือ้หาที่ต้องการซึง่อาจไมส่ะดวกเทา่ที่ควร โดยอาศยัการตัง้ชื่อจดุ
เชื่อมโยงปลายทาง (Named Anchor) แทนชื่อไฟล์ โดยใช้เครื่องมือ    

คลกิเลือกเมน ูInsert > Named Anchor หรือ

คลกิที่ไอคอน Named Anchor ที่แท็บ Common Insert Bar

ตวัอยา่งงาน



เมนู

- การใช้พลงังานอย่างร้ค่าู

- วธิีการประหยดัพลงังาน

- พลงังานทดแทน

1. การใช้พลงังานอย่างร้ค่าู  

2. วธิีการประหยดัพลงังาน

3. พลงังานทดแทน

การใช้งาน Name Anchor

ใช้เครื่องมือ Named Anchor ในการตัง้ชื่อตําแหน่ง

ตา่ง ๆ ในหน้าเว็บเพจ โดยนําเคอร์เซอร์ไปวางไว้

ด้านหน้าหรือด้านหลงัข้อความหรือตําแหน่งที่

ต้องการตัง้ชื่อแล้วคลกิ 

จากนัน้เมื่อต้องการเชื่อมโยงไปยงัตําแหน่งใดที่ได้ตัง้

ชื่อไว้ ให้ใสช่ื่อดงักลา่วในชอ่ง Link โดยพิมพ์

เครื่องหมาย # นําหน้าชื่อทกุครัง้



1. คลกิบริเวณที่

ต้องการตัง้ชื่อ

2. คลกิ

3. ตัง้ชื่อ

4. ผลลพัธ์ที่ได้



1. เลือกข้อความหรือภาพที่

ต้องการสร้างจดุเชื่อมโยงไปยงั

ปลายทาง

2. พิมพ์เครื่องหมาย # 

ตามด้วยชื่อ



การเชื่อมโยงไปยังเวบ็ไซต์อื่น

การเชื่อมโยงไปยงัเวบ็ไซต์อื่นจะต้องกําหนดตําแหน่งของเวบ็ไซต์แบบเตม็ นัน่คือ 

URL หรือชื่อเวบ็ไซต์พร้อมระบชุื่อโปรโตคอล http หรือ ftp ตามด้วยชื่อ server 

เชน่ หากต้องการสร้างจดุเชื่อมโยงไปยงัเวบ็ไซต์ของมหาวิทยาลยัวลยัลกัษณ์

พมิพ์ URL แบบเตม็

กาํหนดตาํแหน่ง

เป้าหมายหรือไม่กไ็ด้



การเชื่อมโยงไปยังเวบ็เพจหรือเวบ็ไซต์อื่น

คลกิที่เครื่องมือ Hyperlink      ที่แทบ็ Common

ตวัอยา่งการสร้าง Hyperlink

ข้อความที่ต้องการ

สร้างเป็นจดุเชื่อมโยง

ระบตุําแหน่ง

ปลายทาง เชน่ ไฟล์

เวบ็หรือ URL
กําหนดตําแหน่ง

เป้าหมาย



การเชื่อมโยงไปยังอีเมล์

เป็นการสร้างจดุเชื่อมโยงเพื่อให้เปิดโปรแกรมรับสง่อีเมล์ที่มีในเครื่อง 

เช่น MS Outlook

คลกิเลือกข้อความหรือภาพที่ต้องการสร้างจดุเชื่อมโยง

ที่หน้าตา่ง Properties ในสว่นของ link ให้ระบทุี่อยูอ่ีเมล์ โดยจะต้อง

ขึน้ต้นด้วย mailto: ทกุครัง้ เช่น mailto:50111111@wu.ac.th เป็นต้น

ตวัอยา่ง การเชื่อมโยงไปยงั E-mail



การเชื่อมโยงไปยังอีเมล์

คลกิเมน ูInsert > Email Link หรือ

คลกิไอคอน Email Link ที่แทบ็ Common

ข้อความที่ต้องการ

สร้างเป็นจุด

เชื่อมโยง

ที่อย่อีเมล์ที่ต้องการส่งู

อีเมล์ไปหาเมื่อคลิก



การใช้งาน Frame Layer และ Forms



การใช้งานเฟรม (Frame)

เป็นการแบง่สว่นพืน้ที่แสดงผลในเวบ็เบราเซอร์ออกเป็นสว่น ๆ แตล่ะ

สว่นจะแสดงไฟล์เว็บเพจที่แตกตา่งกนัได้อยา่งอิสระ

ข้อดี

สามารถแสดงเวบ็เพจหลายหน้าในจอภาพเดียวกนั

สะดวกตอ่การกําหนดพืน้ที่ในการนําเสนอเนือ้หาตามต้องการ

โดยเว็บเพจไมว่า่จะถกูแบง่เฟรมออกเป็นกี่สว่น เมื่อถกูบนัทกึเป็นไฟล์

เวบ็ จะถกูเรียกวา่ Frameset



การสร้างเฟรม

การสร้างเฟรมแบบสําเร็จ (โปรแกรมเตรียมไว้ให้)

1 . File > New > แทบ็ General > Framesets > เลือกรปแบบทีู่

ต้องการ

การสร้างเฟรมจากแทบ็ Layout

2. คลิกที่แทบ็ Layout จาก Insert bar > คลิกไอคอน 

การสร้างเฟรมจากเมน ูModify

คลกิเมาส์ในตําแหน่งที่ต้องการ > Modify > Frameset > เลือกลกัษณะของ

เฟรมที่ต้องการ



1. คลกิ

2. คลกิ

3. คลกิ

4. เลือก



1. เปลี่ยนเป็น Layout

2. เลือกรูปแบบ



1. คลกิ

2. เลือกแบง่เฟรม

ตามความต้องการ

ตวัอย่าง Split



การบนัทกึเฟรมและเฟรมเซต

เมื่อพืน้ที่ของหน้าเวบ็ถกูแบง่ออกเป็นสว่น ๆ แตล่ะสว่นก็คือแตล่ะเวบ็

เพจ ดงันัน้การบนัทกึไฟล์เวบ็แตล่ะเฟรมจงึซบัซ้อนมากขึน้ด้วย โดยแบง่

การบนัทกึเป็น 2 แบบ คือ

การบนัทกึเฟรมเซต 

การบนัทกึแตล่ะเฟรม



การบนัทกึเฟรมและเฟรมเซต

ในการบนัทกึ หากแบง่เป็น 3 

เฟรมจะต้องบนัทกึไฟล์

ทัง้หมด 4 ไฟล์ คือ 

ไฟล์เว็บในแตล่ะเฟรมจํานวน 

3 ไฟล์ 

และไฟล์ซึง่เก็บข้อมลูเฟรม

และลกัษณะการแบง่เฟรมอีก 

1 ไฟล์ page1.htmmenu.htm

head.htm

index.htm



การบนัทกึเฟรมและเฟรมเซต

คลกิเลือกเมน ูFile > Save All เพื่อให้โปรแกรมนําทางด้วยการแสดง

กรอบโต้ตอบ Save as ให้ทําการบนัทกึ Frameset ก่อน แล้วแสดง

กรอบโต้ตอบให้บนัทกึ Frame แตล่ะสว่นจนครบ



การบนัทกึเฟรมเซต

เปิด Frame Panel โดยไปที่เมน ูWindow > Frames

คลกิบริเวณขอบของเฟรม 

จากนัน้ไปที่เมน ูFile > Save Frameset หรือ Save Frameset as เพื่อบนัทกึไฟล์

ซึง่เก็บจํานวนเฟรมและลกัษณะของการแบง่เฟรมไว้ในชื่อที่กําหนด

คลิกบริเวณ

เส้นขอบของ

เฟรม



การบนัทกึไฟล์เวบ็เพจของแต่ละเฟรม

คลกิเลือกเฟรมใด ๆ บนหน้าเว็บ หรือคลกิที่ Frame Panel

ไปที่เมน ูFile > Save Frame หรือ Save Frame as เพื่อบนัทกึไฟล์ในแตล่ะเฟรม

คลกิเลือกแตล่ะเฟรมเพื่อ

บนัทกึจนครบทกุเฟรม



คลกิเพื่อเปิด Frame 

Panel

Frame Panel



การกาํหนดคุณสมบตัขิองเฟรม

คลกิเลือกเฟรมที่ต้องการกําหนดคณุสมบตัิเพิ่มเตมิจาก Frame Panel หรือคลกิ

บริเวณหน้าจอในเฟรมที่ต้องการ

ไฟล์เว็บเพจที่นํามา

ใสใ่นเฟรมยอ่ย

กําหนดให้มีแถบ

เลื่อนหรือไม่

กําหนดเส้นขอบ

และสีเส้นขอบของ

เฟรมกําหนดการปรับ

ขนาดเฟรมชอ่งวา่งระหวา่งเนือ้หา

และขอบของเฟรม



การกาํหนดคุณสมบตัขิองเฟรมเซต

คลกิบริเวณขอบของเฟรมที่ Frame Panel เพื่อกําหนดคณุสมบตัขิองเฟรมเซต

กําหนดความกว้าง

ของเส้นขอบ

กําหนดให้แสดง

ขอบของเฟรม

หรือไม่

กําหนดสีเส้นขอบ

ของเฟรม

กําหนดความกว้างของเฟรมใน

แนวนอน หรือแนวตัง้หากเป็น 

Column



การเชื่อมโยงเวบ็เพจในเฟรม

การเชื่อมโยงเวบ็เพจในเฟรมเหมือนกบัการเชื่อมโยงเวบ็เพจทัว่ไป แต่
แตกตา่งที่การเชื่อมโยงในเฟรมต้องกําหนดวา่ต้องการให้เว็บปลายทาง
แสดงผลที่เฟรมใด 

หรือหากไมต่้องการ ให้เปิดในเฟรม ก็สามารถกําหนดให้เปิดใน
หน้าตา่งใหมไ่ด้

แตห่ากไมร่ะบ ุเวบ็เพจปลายทางจะแสดงผลในเฟรมที่สร้างการ
เชื่อมโยง

ตวัอยา่ง การเชื่อม link ในเฟรมและหน้าตา่งใหม่



การเชื่อมโยงเวบ็เพจในเฟรม

คลกิเลือกข้อความหรือภาพที่ต้องการสร้างการเชื่อมโยง

ที่หน้าตา่ง Properties Inspector ในสว่น target ให้เลือกเฟรมที่

ต้องการให้เว็บเพจปลายทางปรากฏ



เลอืกข้อความที่

ต้องการเชื่อมโยง

เลอืกเฟรมหรือตาํแหน่ง

ปลายทางที่ต้องการให้เวบ็

เพจปลายทางปรากฏ



การใช้งาน Layer



การใช้งาน Layer

เลเยอร์เหมือนกรอบการทํางานของแผน่ใส 

 ซึง่สามารถใสข่้อมลูลงไปได้ และหากนํามาซ้อนทบักนัจะสามารถทําให้

มองเห็นข้อมลูในชัน้ที่อยูต่ํ่ากวา่ได้

Layer 1

Layer 2

Layer 3

ตวัอยา่ง Layer



การสร้างเลเยอร์

คลกิภายในพืน้ที่ทํางานบริเวณที่ต้องการสร้างเลเยอร์ เลือกคําสัง่ Insert > 

Layout Objects > Layer หรือ

คลกิที่ไอคอน    ที่แทบ็ Layout ที่ Insert Bar

ปรับขนาดและ

ตําแหน่ง

เปลี่ยนลําดบั โดยเลเยอร์ที่อยู่

ด้านบนจะมีคา่มากกวา่เลเยอร์ที่อยู่

ด้านลา่ง

ตัง้ชื่อเลเยอร์

รูปแบบพืน้

หลงัการแสดงผลเมื่อข้อมลูยาวเกินกวา่ที่

กําหนด



การใช้งานเลเยอร์

สามารถแทรก   ข้อความ รูปภาพ หรือตารางได้เหมือนกบัทํางานบน

หน้าเว็บปกติ 

โดยหากมีการใช้งาน Layer หลายตวัสามารถเลือกใช้งาน       เลเยอร์

ใด ๆ ได้โดยการคลกิเลือกที่เลเยอร์ที่ต้องการ หรือ เลือกจาก Panels ชื่อ 

Layer ก็ได้ โดย

ไปที่เมน ูWindow > Layers จากนัน้คลิกเลือกเลเยอร์ที่ต้องการ



คลกิเมน ูWindows 

> layers เลือกเลเยอร์ที่

ต้องการ



การใช้งานฟอร์ม (Forms)



การใช้งานฟอร์ม

เป็นสื่อกลางในการติดตอ่ระหวา่งผู้ เยี่ยมชมเวบ็กบัผู้พฒันาเวบ็ โดยใน

การใช้งานจริงของฟอร์มจะต้องมีภาษาโปรแกรมสคริปต์ เช่น PHP CGI 

ASP JAVA และ VB Script ทํางานร่วมกบัฟอร์มด้วย



เครื่องมือต่าง ๆ เกี่ยวกับฟอร์ม

Form : เป็นกรอบของฟอร์มเพื่อบรรจฟุิลด์ตา่ง ๆ

Text Field : ใช้ในการกรอกข้อความบรรทดัเดียว

Hidden Field : ใช้ซอ่นข้อมลูที่ไมต่้องการให้ทราบ

Text Area : ใช้กรอกข้อความหลายบรรทดั

Check Box : ใช้เลือกรายการโดยเลือกได้มากกว่า 1 รายการ

Radio Button : ใช้เลือกได้ 1 รายการใน 1 กลุม่ตวัเลือก

Radio Group : ใช้จดักลุม่ตวัเลือก

ตวัอย่าง Form



เครื่องมือต่าง ๆ เกี่ยวกับฟอร์ม

List/Menu : ใช้สร้างรายการหวัข้อยอ่ยหรือเมนยูอ่ย 

Jump Menu : ใช้สร้างเมนทูี่สามารถเชื่อมโยงไปยงัเว็บเพจหรือเวบ็ไซต์อื่น ๆ ได้

Image Field : ใช้แสดงรูปภาพ

File Field : เป็นกรอบสําหรับเลือกไฟล์

Button : ปุ่ มสําหรับกดเพื่อดําเนินการเกี่ยวกบัฟอร์ม

Label : ใช้ในการแสดงข้อความ

Field set : ใช้ในการจดัรูปฟอร์ม

ตัวอย่าง Form



เริ่มต้นสร้างฟอร์ม

เรียกใช้เครื่องมือในการสร้างฟอร์มจากแท็บ Forms หรือ

เมน ูInsert > Form > เลือกเครื่องมือที่ต้องการ

กําหนดกรอบของฟอร์มที่ต้องการวางลงบนหน้าเว็บ โดยคลกิที่ไอ

คอน Form    และกําหนดคา่การทํางานของฟอร์ม



วิธีที่ 1 เลือก

แทบ็ Forms

วิธีที่ 2 เมน ูinsert 

> Form

เริ่มต้นสร้างฟอร์มโดย

คลกิที่ฟิลด์ Form เพื่อ

กําหนดกรอบของ

ฟอร์มก่อนเสมอ



การแทรก Text Field

ใช้กรอกข้อความ โดยคลกิที่ไอคอน Text Field ในแทบ็ Forms โดย

สามารถกําหนดคณุสมบตัิเพิ่มเตมิได้ดงันี ้

ชื่อฟิลด์

ขนาดความยาวของ 

Text Field

จํานวน

ตวัอกัษรสงูสดุ

กําหนด

ข้อความเริ่มต้น

รูปแบบการ

แสดงผล



การแทรก Textarea

คล้ายกบั Text Field แตส่ามารถกรอกข้อความได้หลายบรรทดั โดยคลกิที่         

ไอคอน Textarea ในแทบ็ Forms โดยสามารถกําหนดคณุสมบตัิเพิ่มเตมิได้ดงันี ้

ชื่อฟิลด์

ขนาดความยาวของ 

Text  area

จํานวนบรรทดัที่

ต้องการให้แสดง

กําหนด

ข้อความเริ่มต้น

รูปแบบการ

แสดงผล

กําหนดให้มีการตดัคํา 

เมื่อป้อนยาวเกินบรรทดั



การแทรก Check Box/Radio Button

Check Box เป็นการแสดงตวัเลือกให้เลือกได้หลายตวั

Radio Button เป็นการแสดงตวัเลือกให้เลือกเพียงตวัเดียวภายในกลุม่

เดียวกนั

ชื่อฟิลด์ กําหนดสถานะ

เริ่มต้น

เป็นคา่ที่จะสง่ไป

ประมวลผล



การแทรก Radio Group

คล้ าย Radio Button แต่ สามารถสร้ างไ ด้ หลาย
ตั วในครั ้ งเดี ยว

ชื่อฟิลด์

คลกิ + หาก
ต้องการเพิม่

ข้อมลู

คลกิ - หาก
ต้องการลบข้อมลู

เรียงลาํดบัข้อมลู

ใหม่คลกิเพือ่แก้ไข

ข้อมลู



การแทรก List/Menu

ใช้แสดงรายการข้อมลูที่มีอยูใ่ห้ผู้ ใช้เลือก เป็นข้อมลูที่มีจํากดั เชน่ ข้อมลูวนัที่ 

เดือน ปี โดยแบง่เป็น 2 แบบ 

คือ Menu และ List โดยตา่งกนัที่แบบ Menu จะแสดงเพียง 1 บรรทดั 

สว่นแบบ List จะแสดงครัง้ละหลายบรรทดัและการเลือกแบบ List สามารถ

เลือกได้หลายรายการ แตแ่บบ Menu เลือกได้เพียงรายการเดียว

แบบ Menu แบบ List



ชื่อฟิลด์

คลกิ + หากเพิ่ม

ข้อมลูคลกิ – หากลบ

ข้อมลู
เรียงลําดบั

ข้อมลูใหม่
คลกิเพื่อแก้ไข

ข้อมลู

รูปแบบ คลกิเพื่อจดัการข้อมลู

คลกิเลือกรายการที่

ต้องการให้แสดง

เริ่มต้น



การแทรก Jump Menu

เป็นลสิต์รายการแบบหนึง่ซึง่สามารถเชื่อมโยงไปยงัเวบ็เพจหรือเวบ็ไซต์

อื่น ๆ ตามแตก่ําหนด

คลกิ + หากเพิ่มข้อมลู

คลกิ – หากลบข้อมลู

เรียงลําดบั

ข้อมลูใหม่

กรอกข้อมลูเพื่อเพิ่ม

รายการในลสิต์



การแทรก Image Field

เป็นการแทรกรูปภาพลงในฟอร์มเพื่อให้เวบ็เพจดสูวยงาม

ปรับความกว้างและ

ความสงูของภาพ

คําอธิบายภาพ

การจดัวางตําแหน่ง
แหลง่ที่เก็บไฟล์

และชื่อไฟล์



การแทรก File Field

เป็นการสร้างปุ่ มสําหรับค้นหาไฟล์ข้อมลู

ชื่อฟิลด์

กําหนดคา่สงูสดุที่

สามารถรองรับได้

กําหนดความยาวของกรอบที่

ใช้แสดงที่อยูข่องไฟล์



การแทรก Button

ใช้สําหรับยืนยนัการสง่ข้อมลูไปประมวลผล หรือใช้ยกเลกิสง่ข้อมลู โดยแบง่เป็น 3 

ชนิด คือ 

Submit (ยอมรับและสง่ข้อมลูไปประมวลผล)

Reset (ยกเลิก) และ None (กําหนดคา่เอง)

ชื่อฟิลด์ ข้อความของปุ่ ม รูปแบบของปุ่ ม


